-
Notifications
You must be signed in to change notification settings - Fork 0
/
new6.c
311 lines (258 loc) · 5.76 KB
/
new6.c
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
// Write a Program to Replace all 0’s with 1’s in a Number.
#include <stdio.h>
// int main(){
// long int i,n=1240522;
// int c=0,j=0,r=0;
// for(i=n;i>0;i=i/10){
// r=i%10;
// if(r==0) {
// j=j*10+1;
// }
// else
// j=j*10+r;
// }
// int k2=0;
// int k=j,k1=0;
// for(i=k;i>0;i/=10){
// k2=i%10;
// k1=k1*10+k2;
// }
// printf("%d",k1);
// }
// Write a C program to find the GCD of two numbers. (greatest common integer)
// #include <stdio.h>
// int main() {
// unsigned int num;
// // Read hexadecimal input from the user
// printf("Enter a hexadecimal number: ");
// scanf("%x", &num);
// // Extract each byte from the integer (big-endian order)
// unsigned char byte1 = (num >> 24); // Most significant byte
// unsigned char byte2 = (num >> 16);// & 0xFF;
// unsigned char byte3 = (num >> 8); //& 0xFF;
// unsigned char byte4 = num ;//& 0xFF; // Least significant byte
// // Print each byte in hexadecimal format
// printf("%02X\n", byte1);
// printf("%02X\n", byte2);
// printf("%02X\n", byte3);
// printf("%02X\n", byte4);
// return 0;
// }
// An unsigned short integer in 8-digit hexadecimal format.
// Output:
// Display the hexadecimal representation of the input integer after swapping its bytes.
// Sample Input
// 12345678
// Sample Output
// 56781234
#include <string.h>
#include <stdlib.h>
// int main(){
// unsigned int n= 12345678;
// char str[20];
// sprintf(str,"%u",n);
// printf("%s\n",str);
// int i;
// for(i=(strlen(str) )/2;i<=strlen(str)-1;i++){
// printf("%c",str[i]);
// }
// for(i=0;i<strlen(str)/2;i++) printf("%c",str[i]);
// }
// int main(){
// unsigned int n=12345678;
// unsigned char *b = (unsigned char*) &n;
// printf("%x\n" ,b[3]);
// printf("%x\n" ,b[2]);
// printf("%x" ,b[1]);
// // printf("%d %d %d",k1,k2,k3);
// }
// int fib(int n){
// if(n==0) return 0;
// if(n==1) return 1;
// return fib(n-1)+fib(n-2);
// }
// int main(){
// int i,sum=0;
// for(i=1;i<=5;i++){
// sum += fib(i);
// }
// printf("%d",sum);
// }
// int sum(int n){
// if (n==0) return 0;
// return n+sum(n-1);
// }
// int main(){
// printf("%d",sum(5));
// }
// int sumofDigit(int n ){
// if(n==0) return 0;
// int r=n%10;
// if(r%2==0)
// return r+sumofDigit(n/10);
// else
// return 0+sumofDigit(n/10);
// }
// int main(){
// int a;
// printf("%d", sumofDigit(52321));
// }
//Program to print perfect numbers in given range using functions
// If sum of proper positive divisors equals to given number then the number is
// perfect number.
// int main(){
// int n1,n,s=0;
// scanf("%d",&n1);
// int i;
// for(n=1;n<=n1;n++){
// s=0;
// for(i=1;i<n;i++){
// if(n%i==0) s+=i;
// }
// if(s==n) printf("%d is PerfecT!!\n",s);
// // else printf("NOOO");
// }
// }
// 1. Print ASCII Value of a Character Using Format Specifier.
// int main(){
// char c;
// scanf("%c",&c);
// printf("%d",c);
// return 0;
// }
// // 2. C Program to Swap Two Numbers
// int main(){
// int a=67,b=45;
// b = a+b;
// a = b -a;
// b = b-a;
// printf("A=67 has become a=%d and B=45 has become b = %d",a,b);
// }
/*
1
2 1
3 2 1
4 3 2 1
5 4 3 2 1
4 3 2 1
3 2 1
2 1
1
*/
// int main(){
// int i,j;
// for(i=1;i<=5;i++){
// for(j=i;j>=1;j--){
// if(j>1)
// printf("%d ",j);
// else
// printf("%d",j);
// }
// printf("\n");
// }
// for(i=4;i>=1;i--){
// for(j=i;j>=1;j--){
// if(j>1)
// printf("%d ",j);
// else
// printf("%d",j);
// }
// printf("\n");
// }
// }
/*
1
1 2
1 2 3
1 2 3 4
1 2 3 4 5
1 2 3 4
1 2 3
1 2
1
*/
// int main(){
// int i,j;
// for(i=1;i<=5;i++){
// for(j=1;j<=i;j++){
// if(j<i)
// printf("%d ",j);
// else
// printf("%d",j);
// }
// printf("\n");
// }
// for(i=4;i>=1;i--){
// for(j=i;j>=1;j--){
// if(j>1)
// printf("%d ",j);
// else
// printf("%d",j);
// }
// printf("\n");
// }
// }
/*
// Armstrong Number
An Armstrong number is an n-
digit number if the sum of its digits, each raised to the power of n, is equal to the original
number itself.
*/
// int armstrong(int n){
// if(n==0) return n;
// int r=n%10;
// return r*r*r + armstrong(n/10);
// }
// int main(){
// int n;
// scanf("%d",&n);
// // printf("%d",armstrong(n));
// for(int i=1;i<=n;i++){
// if(armstrong(i)==i){
// printf("%d\n",i);
// }}
// }
//Hex into a Big Endian
// int main(){
// long int n;//=0x1121ABCD;
// scanf("%x",&n);
// unsigned char *c = (unsigned char*) &n;
// printf("%c\n",c[3]);
// printf("%c\n",c[2]);
// printf("%c\n",c[1]);
// printf("%c",c[0]);
// return 0;
// }
//Binary to Decimal
// #include <math.h>
// int main(){
// long int n;
// scanf("%ld",&n);
// // printf("%ld",n);
// long int i;
// int j=0,c=0;
// while(n>0){
// int r= n%2;
// // printf("%d\t",r);
// j = j+ r*pow(2,c);
// c++;
// n/=10;
// // printf("%d",r);
// }
// // for (i=0;i<c;i++){
// printf("%d", j);
// // }
// return 0;
// }
//GCD using recursion
int gdc(int a, int b){
if(a==0) return b;
if(b==0) return a;
if(a>b) gdc(a%b,b);
else if(b>a) gdc(a,b%a);
}
int main(){
int a,b;
scanf("%d %d",&a, &b);
printf("%d",gdc(a,b));
}